Chat issue with ad blockers when using JavaScript SDK
Incident Report for Sendbird N Virginia 1
Resolved
This issue has been resolved. Sendbird has been removed from the EasyList blacklist.
Posted Jun 02, 2021 - 04:05 UTC
Investigating
Impact: Chat unavailable when using JavaScript SDK along with ad blockers that have privacy tracking enabled

When: Starting Friday, May 28th around 11:30p EDT

Cause:
We’ve recently been made aware of a change made to EasyList, a filter list provider for extensions such as Adblock Plus and uBlock Origin, where our WebSocket domain has been blacklisted. As a result, end users utilizing Adblock Plus, uBlock Origin or any similar service that uses EasyList as a source will be unable to connect to Sendbird.

This issue impacts JavaScript SDK implementations only when used with ad blockers that have privacy tracking enabled.

Next Step:
We are actively engaged with EasyList to address this and hope to resolve it as soon as possible. In the meantime, end users can utilize some potential workarounds below:
- Whitelist the sendbird.com domain (configuration varies from ad blocker to ad blocker; suggested pattern: @@||*.sendbird.com/*)
- Turn off the blocker for the page/site where chat is utilized.

Sendbird does not utilize any user information for retargeting or any advertisement.

Also refer to the following community post for updates: https://community.sendbird.com/t/ad-blocker-issues-in-using-js-sdk/2383.
Posted Jun 01, 2021 - 17:43 UTC